機械学習用のscikit-learnをPython3にpipでインストールする方法

  • 公開日:2018/11/04
  • 更新日:2018/11/04
  • 投稿者:n bit

Google製の機械学習用オープンソースライブラリscikit-learn』をPython3の環境にpipコマンドを使ってインストールする方法について解説します。分類・回帰・クラスタリング・次元削減等様々な機械学習のシーンで利用することができます。

  • Python

この記事は約 分で読めます。(文字)

機械学習用のscikit-learnをPython3にpipでインストール

Googleが開発した機械学習用のオープンソースライブラリ『scikit-learn』はPythonへpipコマンドのみでインストールすることができます

今回はpyenv環境に構築しているPythonに『scikit-learn』をインストールしました。基本的にはどの環境でも同じインストール方法になりますが、もしpyenv内のPython環境にインストールしたい場合は先に下記のページを参考にして環境構築しておいてください。

scikit-learnをPython3にpipでインストール

『scikit-learn』のインストールはpipコマンドで実行するのみです。

『scikit-learn』にはscipyとnumpyが必須のパッケージとなります。まだインストールしていない方はscipyとnumpyを事前にインストールしておきましょう。

下記コマンドを入力してください。

$ pip install scikit_learn

出力結果

Collecting scikit_learn

Downloading https://files.pythonhosted.org/packages/72/c8/7a449014b506d4fed3d7fef5b86c0210ff882a13da82626a12ce9f7db616/scikit_learn-0.20.0-cp36-cp36m-macosx_10_6_intel.macosx_10_9_intel.macosx_10_9_x86_64.macosx_10_10_intel.macosx_10_10_x86_64.whl (7.8MB)
100% |████████████████████████████████| 7.8MB 2.5MB/s
Requirement already satisfied: scipy>=0.13.3 in /Users/xx/.pyenv/versions/3.6.6/lib/python3.6/site-packages (from scikit_learn) (1.1.0)
Requirement already satisfied: numpy>=1.8.2 in /Users/xx/.pyenv/versions/3.6.6/lib/python3.6/site-packages (from scikit_learn) (1.15.2)
Installing collected packages: scikit-learn
Successfully installed scikit-learn-0.20.0

『Successfully installed scikit-learn-0.20.0』と表示されていれば正しくインストールできています。念のためlistでも確認しておきましょう。

$ pip list

出力結果

Package             Version   

------------------- ----------



scikit-learn 0.20.0


インストール作業はこれで完了です。

今日のdot

scikit-learn』のインストールはpipコマンドのみで行えますので特に難しいところは無いかと思います。利用頻度はそれなりにありますのでインストールしておきましょう。

▲ ページの先頭へ戻る

このページの目次

目次